紅牛2008 / 主圖公式 / 通達信捉妖神器主圖和選股指標公式

分享

   

通達信捉妖神器主圖和選股指標公式

2017-04-16  紅牛2008

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上軌:(1+7/100)*DD,COLORGREEN;
上軌1:(1+5/100)*DD,COLORGREEN;
下軌:(1-7/100)*DD,COLORGREEN;
中軌:(上軌+下軌)/2,COLORGREEN;
瘋狂:(1+14/100)*DD,COLORGRAY,POINTDOT;
抄底:(1-14/100)*DD,COLORGRAY,POINTDOT;
上軌紅:IF(上軌>=REF(上軌,1),上軌,DRAWNULL),COLORRED,LINETHICK1;
中軌紅:IF(中軌>=REF(中軌,1), 中軌,DRAWNULL),COLORRED, LINETHICK1;
下軌紅:IF(下軌>=REF(下軌,1), 下軌,DRAWNULL),COLORRED,LINETHICK1;
{中期臨界點90:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),CIRCLEDOT,COLORGRAY;}
{年:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL),CIRCLEDOT,COLORGRAY;}
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
{AMA2:EMA(DMA(CLOSE,CQ2),2),COLORLIBLUE,LINETHICK2;}
{無窮均線:DMA(CLOSE,(VOL)/(CAPITAL)),LINETHICK1,COLORFF00FF;}
{STICKLINE((CLOSE>=中軌) AND (CLOSE>=OPEN),CLOSE,OPEN,3,0),COLORRED;}
{STICKLINE((CLOSE>=中軌) AND (CLOSE>=OPEN),HIGH,LOW,0,0),COLORRED;}
{STICKLINE((CLOSE>=中軌) AND (CLOSE<OPEN),CLOSE,OPEN,3,1),COLORRED;}
{STICKLINE((CLOSE>=中軌) AND (CLOSE<OPEN),OPEN,HIGH,0,0),COLORRED;}
{STICKLINE((CLOSE>=中軌) AND (CLOSE<OPEN),CLOSE,LOW,0,0),COLORRED;}
{STICKLINE((CLOSE<中軌) AND (CLOSE>OPEN),CLOSE,OPEN,3,1),COLORGREEN;}
{STICKLINE((CLOSE<中軌) AND (CLOSE<=OPEN),CLOSE,OPEN,0,1),COLORGREEN;}
{STICKLINE((CLOSE<中軌) AND (CLOSE<=OPEN),HIGH,LOW,3,1),COLORGREEN;}
{STICKLINE((CLOSE<中軌) AND (CLOSE>OPEN),CLOSE,HIGH,0,1),COLORGREEN;}
{STICKLINE((CLOSE<中軌) AND (CLOSE>OPEN),OPEN,LOW,0,1),COLORGREEN;};
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>7.0,O,C,2,0),COLORYELLOW;
STICKLINE(ZDT<-7.8,O,C,2,0),COLOR00FF00;
漲停1:=ZDT>7.0;
不破價:=REF(L,BARSLAST(漲停1));
Z:=(L+H+C*2)/4;
Z1:=EMA(Z,14)COLORBLUE,LINETHICK2;
Z2:=EMA(Z,25)COLORLIBLUE,LINETHICK2;
Z1B:=(Z1-REF(Z1,1))/REF(Z1,1)*100;
Z2B:=(Z2-REF(Z2,1))/REF(Z2,1)*100;
考慮打擊:IF(Z1B>=0 AND BARSLAST(CROSS(Z1B,0))>0,REF((C+O)/2,BARSLAST(CROSS(Z1B,0))),DRAWNULL);
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
啓動:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(啓動,L*0.97,'I金牛啓動'),COLORYELLOW,LINETHICK2;
AA:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
BB:=EMA(AA,2);
TP:=(CROSS(AA,BB) OR CROSS(C,AA)) AND C>=EMA(C,55);
CC1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DD1:=EMA(CC1,9);
主升啓動:=TP AND CROSS(CC1,DD) AND (DD1<=-0.07)*CC1;
DRAWICON(主升啓動,L*0.996,1);
DRAWTEXT(主升啓動,L,'ILSP牛');
DRAWTEXT_FIX(1,0,0,0,'總股本(億):'),COLORFF36FF,LINETHICK3;
DRAWNUMBER_FIX(1,0.09,0,0,CONST(FINANCE(1)/100000000)),COLORFF36FF,LINETHICK3;
DRAWTEXT_FIX(1,0.23,0,0,'流通股(億):'),COLORFF36FF,LINETHICK3;
DRAWNUMBER_FIX(1,0.5,0,0,CONST(CAPITAL/1000000)),COLORFF36FF,LINETHICK3;
DRAWTEXT_FIX(1,0,0,0,EXTERNSTR(0,1))COLOR00FF00;
DRAWTEXT_FIX(1,0,0,0,EXTERNSTR(0,3))COLORFF88FF;
DRAWTEXT_FIX(1,0,0,0,EXTERNSTR(0,2))COLORFFFFFF;

{
選股公式:

DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
金牛啓動:CROSS(AAA-REF(AAA,1),15);
}

    本站是提供個人知識管理的網絡存儲空間,所有內容均由用户發佈,不代表本站觀點。請注意甄別內容中的聯繫方式、誘導購買等信息,謹防詐騙。如發現有害或侵權內容,請點擊一鍵舉報。

    0條評論

    發表

    請遵守用户 評論公約

    類似文章 更多
    喜歡該文的人也喜歡 更多

    ×
    ×

    ¥.00

    微信或支付寶掃碼支付:

    開通即同意《個圖VIP服務協議》

    全部>>